why is bzr so slow?

from the whinge of the day dept: I started a bzr branch of calibre about 2.5 hours ago because I wanted to see how difficult it would be to understand the code and make a few changes. The calibre Get Involved page warns that it can take about an hour….which is excessive to begin with and, worse, a huge understatement. $ date ; ps u -Cbzr Sat Apr 14 15:10:00 EST 2012 USER PID %CPU %MEM VSZ RSS TTY STAT …

comments working again

how embarassing, i make a point of asking for comments and critique on my previous post but comments didn't actually work unless you're logged in.  I only noticed because someone emailed me. It was the admin-ssl plugin.  de-activated now, so comments are working again. A few people tried to add comments according to the log – if you feel like making them again, go right ahead. thanks Craig  

getting the terminal size in python

I’m finally getting around to making myself learn python as more than just a read-only language. Working with Openstack kind of requires it. So far, I like it. Much more than I thought I would as an unrepentant sh and perl using systems geek. And getting over my distaste for the white-space issue is also proving to be much easier than I thought it would (although I still think that block-delimiters like {} make the code easier to read…PyHeresy, I …

rsync and .zfs snapshot directories

zfsonlinux recently added support for visible .zfs snapshot directories, so you no longer have to mount a snapshot to browse/view/recover files from it. This is good, but has caused my rsync backup to zfs script to complain about being unable to delete files in the .zfs directory (which is in the backup but not in the source). e.g. sending incremental file list rsync: delete_file: unlink(.zfs/snapshot/2012-03-31/vmlinuz.old) failed: Read-only file system (30) rsync: delete_file: unlink(.zfs/snapshot/2012-03-31/vmlinuz) failed: Read-only file system (30) […] cannot …

fstrim and XFS

Does anyone use fstrim on an XFS formatted SSD partition? I’ve got two systems with XFS root partitions that fstrim seems to do (almost) nothing on, but it seems to work correctly on another system with formatted with ext4.

How to set the application icon for chromium

This has been a minor annoyance for the last few months, and I've finally figured out how to fix it: Sometime within the last few months, an upgrade prevented Chromium from finding its application icon…with the result that when minimised (or displayed in the panel window list or Alt-Tab) it used the default application icon. It looks to me as if the problem is that Chromium is now looking for chromium-browser.svg but chromium.svg is what's on my debian system. To …

one of the reasons i like zfs…

I got home from work tonight and zfs had reported that one of the disks in my main pool was dying. no great problem. insert a disk i had spare, and run zpool replace like so: ganesh:~# zpool replace -f export scsi-SATA_WDC_WD10EARS-00_WD-WMAV50933036 scsi-SATA_ST31000528AS_9VP16X03 and now it’s just a matter of waiting until the data has “resilvered” and i can remove the old dying drive. ganesh:~# zpool status export -v pool: export state: ONLINE status: One or more devices is currently …

problems with Linux and Aten CS1784A KVM switch

Dear lazyweb, I bought an Aten CS1784A DVI+USB KVM switch a couple of months ago. I’m pretty happy with it except for one annoying problem. It has a Dell multimedia USB keyboard plugged into it (picked it up from a swap meet for $15 – nice. it's a pretty good keyboard in its own right but i mostly bought it to match what I use at work), and a Logitech MX518 mouse connected. Also two computers – one runs Linux …

some more reasons to hate gnome shell

Non-resizable configuration windows.  I have a 1920×1200 screen but the window manager provides no way to resize windows like the System Settings window.  Result is that the window is quite small and, worse, has a scroll bar for no good reason when another hundred or so vertical pixels would easily display everything. Even another 30 or so horizontal pixels would allow more icons per line under Hardware, reducing the number of lines, and again allowing the entire list of available …

Xen VMs won’t start: “Cannot plug VIF”

I've been unable to solve this problem for a few weeks now, so i'll try posting it to my blog – maybe someone out there knows the answer.  Would very much appreciate a clue on this one. I've got a VM on a citrix xenserver 5.0.0 machine that won't start. it was running fine until it was rebooted on a Fri afternoon, a few weeks ago. Starting it from the (windows-only) xencenter GUI results in: "This VM cannot be started, …